You are not connected. Please login or register

Phason Support Forum » Frequently asked questions (FAQs) » All controls » Relay turns off but the load remains on

Relay turns off but the load remains on

View previous topic View next topic Go down  Message [Page 1 of 1]

First, bypass the control by removing one wire from the relay terminal -  this should turn off the load.
If it doesn't, you've got wiring problems that you need to fix.
If it does, turn off the power to the load and continue.

Next, test that the relay works properly using this post.

When a load doesn't turn off and it's not a control relay or wiring problem it's usually because of a third-party solid state relay between the control and the load. This could be external or internal to the load often found on heaters.

There is a snubber circuit across the control relay to protect it against transients. This will allow a small amount of current to pass even when it is off (open). This could cause a small solid state relay to remain on when the control relay is off. This will not be the case with a mechanical relay.

One solution is to put a 100W bulb across the hot and neutral of the coil (input) of the solid state relay (not across the control's relay). This will shunt any leakage current through the bulb when the control relay is off, even though it may not be enough current to turn the light on.

Another solution is to get a larger relay that requires more coil current to turn on. Aim for something larger than 250mA.

View user profile http://www.phason.ca

View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum